Opened 6 years ago

Last modified 6 years ago

#21 new defect

SNAP works in SMP system with more then 4 cores ??

Reported by: ecsnl Owned by: somebody
Priority: major Milestone: next
Component: component1 Version:
Severity: highest Keywords:
Cc:

Description

http://www.os2world.com/component/option,com_smf/Itemid,63/topic,5896.0/

Runs well here on a Phenom II X6. However, with SNAP video enabling 4 cores is still the limit. (6 cores only work with plain VGA, SNAP hangs at WPS boot-up)

And the reactor temperature widget for XCenter does not show anything except of "Zzz".
Does anybody have a working version that can show system/CPU temperature as measured using ACPI?

Cheers
Andreas

Change History (8)

comment:1 Changed 6 years ago by ecsnl

I invited Andreas to post comment back to this ticket. Also see if Panorama works on his system in 6 core SMP mode with Panorama.

comment:2 Changed 6 years ago by Grimus

Just tried with Panorama on a freshly installed eCS 2.1 system and ACPI 3.20.03. 6 cores work without problems. All active, WPS comes up system sounds play well. Shortly after boot, all CPUs but one are set to 0% load, so it seems that HLT works as well.

So, the culprit is SNAP that prevents my computer from using all 6 cores. On the other hand it enables me to run the WPS across two LCDs next to each other, so I cannot switch to panorama.

comment:3 Changed 6 years ago by Grimus

Any news on this bug?

comment:4 Changed 6 years ago by abwillis

When you say hangs at loading WPS, is the screen still black at that stage?
How long have you let it sit?
I as these questions to see if there is any relation to what I have seen in newer hardware where it will hang for hours where it says (with altf2 boot) pmshell was launched before finally loading the WPS and then be like there was never a problem.

comment:5 Changed 6 years ago by rousseau

Hi,

When the screen stays blank and the WPS does not come up, try this first:

  • hit ALT-F1 right after the system boots
  • press F2 to get into a command prompt
  • cd ?:\snap
  • gaoption usesysmem off

If you see the SNAP logo your WPS will most likely come up on next reboot.
If the program seems to hang, press Ctrl-C to hopefully terminate it.
Your WPS will then probably still not come up on next reboot.
You could experiment with the other gaoptions like AGP speed, etc.
If gaoption show does not do a long delay before returning, you might get lucky.

If all the above fails then try the stuff below:

  • SET SDD_INTCURSOR_DISABLE=Y in CONFIG.SYS
  • rem-out UNIAUD16.SYS and UNIAUD32.SYS

When using ACPI:

  • rem-out APM.ADD
  • rem-out ACPIDAEMON.EXE
    (APM.SYS and APMDAEMN.EXE sould be remmed-out already)

When not using ACPI:

  • rem-out APM.SYS
  • rem-out APMDAEMN.EXE
    (APM.ADD and ACPIDAEMON.EXE should be remmed-out already)

Also,

  • rem-out your NIC driver

You can do all of the above at once and then reboot.

If the WPS still does not come up and you use ACPI, then play with the flags
of ACPI.PSD, like: /VBE /[A]PIC /SMP, etc.
You can find what flags ACPI.PSD can use in ?:\eCS\ACPI\DOC\ACPI.TXT.

If the above works for you, please take the effort to track down the culprit
and post it here.

Thanks,

Ben.

(who is busy removing all SciTech? references :-)

Last edited 6 years ago by rousseau (previous) (diff)

comment:6 Changed 6 years ago by Grimus

Hey, great to see that some things are moving at the SNAP front. Will give your suggestions a try this evening and report the results.

comment:7 Changed 6 years ago by Grimus

Hooray!! I am happy to report that installing the latest ACPI package on a fresh eCS 2.1 business installation, then SNAP 3.1.8 (registered version) seems to have solved the issue. No more hangs on boot/re-boot. All 6 cores work like a charm. I did not have to comment out anything - both APM and ACPIDaemon are started from config.sys.

Now trying with a production system.

comment:8 Changed 6 years ago by Grimus

Latest ACPI installed on my production system with SNAP 3.1.8 (SciTech? version registered) in dual screen (2x 1600x1200). Boots and works well. Just have the feeling that video got even slower than before - especially when the WPS comes up.
But in termsn of 'does not work with > 4 cores', the ticket is no longer valid for me. Installing latest ACPI package (3.21.02) solved this (issues using WarpIN with all SMP optimized dlls).

Note: See TracTickets for help on using tickets.