Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#42 closed defect (fixed)

Context menu in Flash > 10.0.45 is corrupt

Reported by: dmik Owned by:
Priority: major Milestone: Beta1
Component: wrapper Version: Technology Preview 2
Severity: Keywords:
Cc:

Description

When you press the right mouse button when the mouse is over the Flash object, the Flash context menu should appear. However, in newer flash versions, only a narrow vertical strip is shown instead of the menu. Looks like some font metrics or menu item dimensions are calculated incorrectly.

Change History (3)

comment:1 Changed 8 years ago by dmik

I will try to look at it before releasing Beta 1 to see if it's possible to quickly fix this.

comment:2 Changed 8 years ago by dmik

Resolution: fixed
Status: newclosed

The problem is fixed in Odin r21961:

Support MIIM_FTYPE/MIIM_STRING flags properly in InsertMenuItem/SetMenuItemInfo.

The old Wine code doesn't seem to be aware of them. This in particular fixes the
broken context menu of newer Flash (see Flash ticket #42).

I checked all Win32 Flash DLLs we have (up to and including 11.1.102.55) and the menu now works well.

comment:3 Changed 8 years ago by jojo

Nice job, good to see you're making so much progress!

Joachim

Note: See TracTickets for help on using tickets.