Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#34 closed defect (fixed)

Flash 10 sometimes doesn't recognize mouse clicks

Reported by: djcaetano Owned by:
Priority: major Milestone: 0.4.0
Component: wrapper Version: Technology Preview 2
Severity: very low Keywords:
Cc:

Description

Every now and then I find a site that just ignores the mouse clicks when running inside eComStation's Flash 10. Just as an example, this is one of those sites: http://www.studioamotel.com.br/ . The top menu simply ignores mouse clicks. It works on Windows' Flash 10.

Change History (12)

comment:1 Changed 9 years ago by jojo

Incorrectly set as duplicate of ticket #11 - please consider the info in the eCS bugtracker, http://bugs.ecomstation.nl/view.php?id=2662

comment:2 Changed 9 years ago by Silvan Scherrer

Milestone: Beta1Beta2

comment:3 Changed 8 years ago by dmik

I can't say that the site from the description ignores mouse clicks in the menu area -- here it removes highlighting from the previous menu item when I click a new one. But it doesn't change pages indeed (as it does under e.g. Mac OS).

This problem may be a generic version of #29. It may have something to do not with the mouse clicks themselves but with following links (= taking actions) that clicks represent -- since in a lot of cases mouse click work well (e.g. the youtube.com video player controls, [X] buttons in the advertisement popups, etc.).

comment:4 Changed 8 years ago by dmik

This defect may have something to do with Odin ticket #3.

Also, #47 can be another consequence of that.

comment:5 Changed 8 years ago by dmik

And #57 too.

comment:6 Changed 8 years ago by dmik

Severity: very low

Now, after fixing directory creation, I get the following in flashlog.txt (created by the debug version of Flash) when I try to click e.g. the "Studio A" menu item:

*** Security Sandbox Violation ***
URL for window '' halted (AllowScriptAccess is 'always'): http://www.studioamotel.com.br/studio_a

comment:7 Changed 8 years ago by dmik

One guess is that the security doesn't let this click/link pass through because the window name is empty (which looks weird). Probably somehow Flash can't detect the proper window name (valid values are _self, _top etc).

comment:8 Changed 8 years ago by Silvan Scherrer

Milestone: Next0.3.3

comment:9 Changed 8 years ago by dmik

Did some more analysis of the Odin logs. It looks like Flash tries to check the Firefox executable when one presses a button that should open a different page but this check fails and this leads to a security sand box violation. I'm trying to understand what check is that.

comment:10 Changed 8 years ago by dmik

Resolved the firefox executable resource problem (a series of Odin commits is to follow).

However, this didn't resolve the original problem. The only change is that the log now says 'sameDomain' instead of 'always' for AllowScriptAccess? for some reason. Will dig a bit further. I may be close.

comment:11 Changed 8 years ago by dmik

Resolution: fixed
Status: newclosed

This works after doing #69.

comment:12 Changed 8 years ago by Silvan Scherrer

i also tested the above link and it works. i had a crash when going back with the ffox back button. but can't reproduce it always.

Note: See TracTickets for help on using tickets.