Opened 10 years ago

Closed 9 years ago

#26 closed defect (invalid)

Hard hang at any sign of FLASH content

Reported by: dgbisse Owned by:
Priority: Feedback Pending Milestone: Beta1
Component: wrapper Version: Technology Preview 2
Severity: Keywords:
Cc: dgbisse

Description

After installing all of the components of FLASH 10 Pre 2 My Firefox instantly hangs the whole system if there is any trace of FLASH on a page that I go to. It even hangs when FLASHBLOCK is active. The mouse won't move, there is no apparent background activity, and the only way out is by force power off, or use the reset button. This happens even if I turn off all but one processor. (at least Pre 1 worked when I did that).

The system is an Asus M3A78-EM board, with AMD quad core processor and 2 GB of memory. I use ACPI with /SMP /PIC. I use UNIAUD from Uniaud195-211.zip.

I can find no trace of any log file, or errors that might be related. This system is working well, until I try FLASH 10 Pre 2.

Change History (6)

comment:1 Changed 10 years ago by dgbisse

Cc: dgbisse added

OOPS! I meant to say that I am using UNIAUD from Uniaud195-1924.zip.

comment:2 Changed 10 years ago by Silvan Scherrer

did it work with flash10 tp1?
what kernel do you use? as i know some osfree kernel did exactly what you describe.

comment:3 Changed 10 years ago by Silvan Scherrer

the smp problem is known. we try to solve that while doing java development. it's a common odin problem.

see also http://svn.netlabs.org/odin32/ticket/28 for progress an that

comment:4 Changed 9 years ago by abwillis

Odin ticket 28 has been resolved but that appears to not have been the cause of SMP problems with Flash. I marked seamonkey.exe as mpunsafe to verify that it was SMP related. I find that I can normally CAD and kill the process (using hard kill). The odd thing though is that I found if I hit Ctrl-Esc and wait 30s or so and I will get a popup wanting to kill seamonkey (and it will generally kill it) but when it pops up the video will fast forward to where it should be and then play the video normally but there is no audio. If I hit ESC to close the popup then the video will stop again (ctrl-esc will generally allow me to repeat the process). Here the lockup does not occur until I allow the flash content to play (flashblock IOW will prevent the lockup here) and it may not happen immediately (though normally it is very quickly) but sometimes plays for a bit before locking up.
I am not sure what the significance of the fact that the video will restart while the popup is active but thought it an oddity.

comment:5 Changed 9 years ago by Silvan Scherrer

Priority: majorFeedback Pending

please test with odin 0.8.2 and latest flash dll. latest flash dll should be available at betazone

comment:6 Changed 9 years ago by Silvan Scherrer

Resolution: invalid
Status: newclosed

also no feedback since longer. we believe it's the same as #28

Note: See TracTickets for help on using tickets.